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Part 1: The Setup
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Introduction to 3DCombine
Creating depth illusion
The 3Dcombine is an application that attempts to create a stereo
image from a flat 2D image, using depth maps or creating them based
on information in the flat image.

A depth map is nothing else than a grey tone image with distance
information turned into a grey shade. White areas indicate “nearby”
and black areas “in the far distance”. Overlaying such a map with the
colour image will produce a stereo image with a left and right eye
picture. Both pictures are slightly different, in the same way as your
left eye perceives objects from a slightly different position as your left
eye. The difference, the parallax, provides depth information to your
brain. In addition, the available perspective in the 2D image helps to
enhance the illusion in 3D.

3DCombine to convert 2D to 3D
3DCombine analyses the image, calculates a depth map and produces
the right eye image based on the combination of depth map and left
image. For a movie it does the same as for an image – a movie is
nothing else than a sequence of images.
The program can run in two modes:
•
•

For most, the use of a “Guides” wizard type conversion will
suffice. These are discussed in Part 2: Basic operations.
For those the want to tweak the input a bit and be in full
control, the use of filters and manual steps of the process are
available. These are discussed in the other parts of this
document.

It all starts by opening one or more 2D images or a movie file.
Producing depth maps and creating a 3D image takes computing
power. Therefore converting a movie may take upto 5 to 8 times its
running time: an hour of movie runtime can take 8 hours processing
time to produce a 3D equivalent.
In this respect 3DCombine takes a different (and more credible) approach
than many instant 2D-to-3D converters built in tv sets and projectors or
offered as “professional” software. They often only apply a horizontal shift
of left and right image, creating a window behind which the (flat) scene is
positioned. A standard depth map (somewhat into the back at the top and
at the front at the bottom of the picture) may enhance the depth effect.
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The resulting stereo image can be previewed using the “Preview 3D”
button. This preview can be done in various ways. The most common
ones are:
•

•

•
•
•
•

Various Anaglyph – differently coloured picture for left and
right eye that can be viewed on paper or screen using a pair of
glasses with the right colours (red/cyan, yellow/blue or
magenta/green). The true colours are somewhat distorted but
the depth effect is easily seen
Parallel – a popular full colour left and right image positioned
next to each other. It needs some training to allow your eyes
to look straight ahead while focussing, causing both pictures to
merge in the middle to a 3D image. Also known as “side by
side”
SBS/Sensio – similar to parallel buth with images squeezed by
factor of 2. Used for 3D tv sets and projectors. Aslo known as
“Half Size-by-Size”
Above/Below Full – similar to parallel but with images
positioned on top of each other.
Above/Below – similar to SBS/Sensio, but left and right image
are positioned on top of each other. Only for tv set and
projector use. Also known as “Top-Bottom”
Cross eyed – similar to parallel, but images are ordered rightleft. You need to train your eyes to look cross eyed to see the
correct picture in each eye. Some find this easier to do than
parallel viewing.

When satisfied, you save the result in an output file, using the selected
3D option described above, by clicking the “Save Image” or “Save
Movie” button.
Examples are shown online at
https://www.3dcombine.com/Formats.html

Depth map limitations
Depth map may be very useful but also have their limitations. It’s not
the perfect selection, “das Gelbe vom Ei”, “het ei van Columbus”, “just
the thing”. It is expected that with better understanding of artificial
intelligence and self-learning patterns a number of these limitations
might be reduced or eliminated in future.
The main problem with depth maps is that by creating depth some
information must be added to the background that does not exist in
the 2D image. Look at the illustration below. At the left it is shown how
the picture was taken of a black object against a background. The part
of the background hidden behind the object is indicated as a blue
“hidden” range.
Using a depth map tries to create two slightly different pictures, as if
seen by a left and right eye. For both eyes however, being positioned
differently from the camera lense, each seems some of the
background hidden for the lense. This part of the background is not
stored in the image. It is non-existent. The two areas are indicated in
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red in the figure. But that area has to be “made up” by some algorithm
that usually borrows some information of a nearby area and duplicates
it in the uncovered areas. This may go unnoticed or be very subtle, but
when not, it spoils the stereoscopic illusion. Those situations reveal
artifacts of the algorithm calculations.

Some of the limitations and problems with depth maps you may see
are listed below:
•

•
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Some objects are calculated/guessed at the wrong distance.
This can be noticeable especially in well known forms like
human bodies. A clear dividing line between arm and T-Shirt
may result in an impression that the arm is way behind (or in
front) of the T-shirt. Or a shoulder dislocated from its arm. Or
your leaning on a staircase that seems at a more remote
distance. The picture below shows two arms leaning behind a
wooden branch. The lower arm however seems chopped off
when seen in stereo (right image – see with anaglyphic
red/cyan glasses)

In stereo movies they give a “this cannot be true” experience
where the depth illusion is severely disturbed.
Backgrounds hidden by an object in 2D are not entirely hidden
looking by the left eye or right eye. This “revealed”
background does not exist in the 2D image and has to be
“made up” by the application. This is done by copying similar
information from nearby areas in the background.
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•

Artifacts are created where information must be added to the
picture where it is not available. It’s “made up” from
neighbouring areas in the image. Often this goes unnoticeable
to the viewer but on occasion the algorithms produce visible
artifacts.
These can be small (see right side of penguin in picture below,
taken in Hobart, Tasmania) although the eye quickly picks up
on “odd” and “unexpected” edges.

Sometimes they really are disturbingly present such as below
with an arm near a window.

•
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Deformation – algorithms may sometimes produce wrong
results, often resulting in crooked lines that are supposed to
be straight. (see flag pole in picture below, taken in Hobart,
Tasmania). In movies this may result in a wiggling picture as
the deformation may change from image frame to image
frame.
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Artifacts and deformations can be manually removed using an image
editor. 3DCombine can create a depth map. You can edit this in an
image editor to correct various shades of grey and recreate the image
using the corrected depth map.
In movie frames (and a movie has many frames – 24 for each second)
that is a labour intensive work. It explains why hundreds of people are
involved in the post-processing of a 2D movie to create a 3D movie.
Animated movies are simpler to recreate in stereo. The movie creation
software can recreate the movie for the other eye using a software
camera position slightly different from the original one. This way it
creates a left and right eye image automatically that can be used in a
SBS or MVC (Multiview Video Coding) movie.
Some of these artifacts can be reduced when you apply one or more
filters on the image before saving the result as 3D output file. Filters
are described in Part 4: Creating Or Improving 3D Effects.

Installation
The installation of 3DCombine is a no-brainer. You copy the installation
file from the application web site https://www.3dcombine.com/ . The
application is initially free to use for 16 days to see if it fits your needs.
During installation it checks if the required runtime C++ libraries are
installed. If not, it offers to install these too.
Registration is done if you decide to purchase the application. After
the trial period it reverts to a “free” application with limited
capabilities – none of which are allowing you to use what 3Dcombine
is supposed to do: generate stereo images.

Things to think about with movies
A 2D movie version must fit aspect ratio
If you want to create a stereo movie for tv set or projector, you need
to ensure that the source material fits the current widescreen aspect
ratio of 16:9 .
Movies that are older are likely to be in Academy format with aspect
ratio 4:3. You need to create a new version of the movie that has an
aspect ratio of 16:9. This means that the 4:3 image is embedded in the
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middle of a 16:9 image. It is surrounded by black bars on the left and
right side of the image, centering the 4:3 movie picture.

Output choice
SBS/Sensio - Stereo movie or stills for tv or projector
If you want to show a stereo image or run a 3D file on a 3D television
set or 3D video projector, remember that these apparatus are using an
aspect ratio 16:9 (often by 1920 x 1080 pixels) in “Full High Definition”
size.
The stereo image or movie is made as side-by-side image or movie.
Because both left/right frames need to fit within a width of aspect
ratio 16:9 (and often fit a width of 1920 pixels), their horizontal size is
squeezed by a factor of 2. This results in squeezed images of aspect
ratio 8:9.
When displayed by tv set or projector, these will unsqueeze both
left/right images back to ratio 16:9 each and display them in rapid
succession. A pair of active shutterglasses ensures the left image only
reaches the left eye and the right image the right eye. This way a depth
impression is obtained.
Using 3DCombine’s output setting SBS/Sensio creates squeezed
images to aspect ratio 8:9 (usually 960x1080 pixels). Positioned next to
each other they fit a 16:9 (often 1920x1080 pixels) image.

12
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When the tv set or projector is set to display 3D in “Side by Side” (SBS)
mode, it allows the produced movie to be shown in correct ratio on
screen.
Parallel - Stereo movie and stereo still images not for tv or projector
If you have a pc with capable video graphics card and monitor to
display stereo movies and pictures on the monitor, any 3D format may
work.
Selecting the first option “Parallel” results in two frames where left
and right have the right proportions and are positioned next to each
other.
The pc monitor will play the movie as intended when set to 3D SBS
mode. Stills can be shown the same way. If further processing is
needed, the stills can be opened in “Stereo Photo Maker” as a “stereo
image”.

Resulting output
3DCombine produces an output file in the selected .avi, .mp4 or .xxx
format – depending on your choice. However, some video editors will
not accept this output and also Windows Explorer doesn’t give a
preview if you have set it to display files as small or large icons. This
may be caused by the fact that it outputs a variable bitrate rather than
constant.

The above illustration shows how a 3D movie “Stingray” was created
by 3Dcombine. In Windows it is shown by the icon of the default
application to open an .mp4 movie (in this case, the freeware VLC
player is used).
To make it acceptable as input for a video editor such as Cyberlink’s
Power Director, you need to transcode the output file into a new file
with constant bitrate , keeping most of the characteristics of the old
one to avoid degradation in quality.
Use the free MediaInfo tool to inspect the produced output and reuse
as many of the characteristics for the transcoded new output. There
are several video converters on the market, such as HD Video
Converter Factory which has conversion facilities in its free version and
more in its paid version.
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The transcoded file is displayed in Windows Explorer as a (SBS) film
frame icon with a little icon indicating the application (VLC) to open it.
The destination file must also be suitable for the targetted device.
•
•

•

For 3D tv sets and projectors, a half side-by-side image is
required. Select the SBS/Sensio output option for this.
For viewing on ordinary tv sets, pc monitors and other play
devices, stereo viewing is often possible using anaglyphic
output. This requires the viewer to look through the
appropriate coloured pair of glasses.
If both 3D and ordinary tv sets are targetted you need to run
the application twice: once for each output. Alternatively, you
create the SBS stereo movie and use a 3D capable video editor
to create an anaglyphic movie from this. This is often a lot
faster than re-running 3DCombine (10 minutes versus 4 hours)
since the time consuming depth map process can be skipped.

Examples of output formats are shown online at
https://www.3dcombine.com/Formats.html
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Part 2: Basic operations
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The 3DCombine interface
The user interface shows itself when you start the application from the
Start menu or an icon on the desktop.

The two main components are the menu bar with buttons below it.
And the two images that show whatever it is you imported into the
application.

Button Ribbon

The buttons ribbon can be unlocked and positioned elsewhere. If you
click on its double-lined left edge, it becomes unhinged and you can
position it to another side of the interface or completely separate of it
– even outside the interface.
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For basic operations, you will mostly look at the “Guides” menu
option. The other buttons and menu options are invoking more
advanced features.
Initially you may want to use all the help prompts available in the
Guides mode. Once you know the drill, you may want to disable these
prompts and get right to it (see section “Guides” on page 20 on how to
do this).

Preview 3D Button
The “Preview 3D” button determines what you see after the
processing or after you imported a left and right version of an image or
movie.
Pressing “Preview 3D” will show the combination of left and right as a
stereoscopic image or movie, depending on the setting of your desired
3D output .
When it asks for the stereo format for the output file, this button
allows to view either the left and right images separately or combined
in the way the stereo format specifies. This can be parallel but also a
single anaglyphic image made out of both images.
•
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When clicked (button looks pressed in) the image is shown as
the 3D output specified. That may be 2 images side by side but
also a single anaglyphic stereo image.
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•

When unclicked the left and right images are shown
separately.

This preview may help decide if you’re satisfied and want to click the
“Save Image” or “Save Video” next to create the output files.
For a closer look you can preview full screen by clicking on “Full
Screen” button. Any mouse or keyboard click will revert you to the
usual application interface size on the desktop.

Redraw button
Redraw refreshes the images in the left and right panels. This can
be useful if you've resized the window and want to resize the
images displayed to match.

Cancel Button
When an operation is cancelled during the process, the resulting
output file is closed and can be used upto the point where the cancel
was invoked. This could be part of the movie or the first set of images.
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Guides
3DCombine makes it easy to quickly start using the software directly
and add manual enhancements and improvements later when you get
familiar with its capabilities.
The “Quick Start” method is to use the “Guides” menu option.

These guides help you to create a stereo movie (video) or still image.
By default guides prompts are enabled. This is seen by the clicked-in
appearance of the Guides > Prompt user menu button.

Disable prompts by unpressing the button.

Using Guides, automatically “Preview 3D” enabled (clicked), showing
the left image and created right image when “parallel” is selected or a
single anaglyphic stereo image.

20
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Still Image
The guide options to create a stereo image from a flat 2D image are
listed in the menu.

The process of creating a stereo image from a flat 2D image is
essentially the same as creating a stereo movie. After all, a movie is
nothing else than a large number of still images displayed in rapid
siccession, often at 24 frames per second.

Multiple images in batch
Unlike movies, you can process many images in sequence by creating a
batch job. When the application asks to specify a single image, select a
number of them (as block using the SHIFT key while selecting first and
last image, as individual images by using the CTRL key while clicking on
each selected image).
The application asks for an output folder rather than a single name.
A batch job is limited to images stored in a single folder and the results
are also written to (another) folder. In “Guides” mode it expects only a
set of 2D images as input.
When in batch mode, two additional buttons appear in the button
ribbon that allow you to move to the next or previous image before
using the “Save Image” button to store all 3D processed images.

If you are on the first or last image the “Back” and “Forward” buttons
respectively, remain active but when clicked stay on that first or last
picture.

Intelligent
If you select the “Intelligent” process, the application handles all the
steps. You only indicate the image file to process.
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Next you specify the format for the output file – usually parallel, side
by side or anaglyphic.

Next click the “Save Image” button, specify the output file specification
and sit back a few seconds for the output file to be created.

Landscape
Identical to “Intelligent” but with a different algorithm that is more
suitable for wider pictures while still producing eye-pleasing stereo
effects. Landscape mode is for photos of landscapes, e.g. mountains,
trees, fields etc as opposed to referring to the orientation of the
image.

With Depthmap
Creating a stereo image
This choice allows you to specify a 2D image as left side image and a
depth map as right side image.
3DCombine will use both to create a right side image slightly different
from the left one. Together the give the stereo depth effect.
When this guide is selected, it first asks you for the 2D image as left
image.

Next it requires another file containing the depth map for this image. If
you need to create it, read how to do this further down this section

22
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Next you need to specify the depth (disparity between both images).
The suggested value of 0.20 is a good one to start with.

One but last step you need to choose whether to perform some postprocessing which may or may not improve the final result. You can skip
both options.

Finally, indicate what type of stereo image the final result must be:
usually parallel, side-by-side or anaglyphic.

Click the “Save Image” button and store the result in a file.

Creating a depth map
A depth map is a grey tone image overlayed with the 2D image. The
grey tones indicate the virtual distance of an object on the 2D image to
the viewer. A white area indicates nearby, black means far away. Grey
tones are somewhere in between.
To create a depth map for a 2D image, you need an image editor that
can work in layers. PhotoShop, PaintShop or the freeware Gimp are
suitable editors.
For Gimp a set of macros have been defined as “DMAGn” (n=1 to 9) by
Ugo Capeto. A single grey coloured stroke over an object and the
macro will fill the entire object with that shade of grey. A quick way to
have a depth map. See appendix Photo editing on page 74 for details.
For the manual method of making one, read on.
An example of the process is shown in the illustration below. At the
left you see a stack of grey layers. The white parts in the top layers
indicate transparency. Looking from the top you see a single depth
map in shades of grey, as illustrated at the top right. Because higher
levels cover the darker lower levels, those top layers can paint over the
lower ones.
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Combined with the 2D photo at the bottom right, a 3D picture can be
created, as shown in an anaglyphic format in the figure below.

The steps to undertake to create a depth map in an image editor, are
the following:
•
•
•
•

•
•
24

Open the layer-capable image editor for the image
Create a new transparent layer on top of the image
Select (almost) white as brush colour and cover all nearby
parts of the frame white
Create a new layer, select a somewhat more grey paint colour
and cover all parts that are a little furter away with this grey
shade. You can paint over the earlier whiter coloured layers
parts – in the end that won’t show.
Repeat this for as many shades of grey as you want to include.
The final layer is an image-filling black colour
3DCombine - manual

•
•
•
•

•

Re-arrange all layers upside-down. That is, the first layer (with
white) goes on top of the layer stack. The last layer (entirely
black) goes on the bottom and covers the entire image.
The result should be a greytone image, a depth map, of the
image while the image itself is totally covered and invisible.
Save the file with its layers in case you want to correct it later
using the image editor by adding layers or modifying existing
ones.
Save the image again as a flat “depthmap_nnn.bmp” file in
the same folder as where 3DCombine stored its own
depthmaps. You must adhere to this naming convention. Do
not use leading zeroes. So use “depthmap_3.bmp”, not
“depthmap_003.bmp”. Other formats as .jpg are also allowed,
but .bmp are lossless and better for accurate depthmaps.
Repeat these steps for all key frames.

Where areas gradually disappear into the distance (like a sea surface
or road), you should not use a single grey tone (which indicates a fixed
distance) but rather a gradient running from one lighter grey tone
(suggesting nearby) to a different darker grey one (suggesting further
away).
The second grey layer in the illustration shows how such a gradient is
needed to give the sea level the depth from front to horizon and the
rocky shoreline ar a fixed distance. It is shown again in the illustration
below.

Consult your image editor manual or help files to find out how to do
this in your image editor.

Automatic creation of depth maps
For each 2D image or each first keyframe and last keyframe of a scene
that you select yourself rather than letting 3DCombine determine
these (and often not doing it right) you can also generate depthmaps
automatically. For this, you need to load the 2D image or movie as left
side file (File > Open Image > 2D Left or File > Open Video > 2D Left).
3Dcombine - manual
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You can play through the movie (or jump to the next image) until the
desired frame is shown.
Next you can use the “Depth” button to create the depth map. See the
section Depth Button on page 62 for details.

From Portrait Mode Photo
Intended for use on photos taken with a mobile phone that has
“portrait mode” available. This mode blurs the background around the
object. The phone software figures out what the background parts and
has a depth map as part of the picture. 3DCombine neeeds to access
this depth map to use it to produce a 3D image.
Using the “Guides” option Image 2D to 3D > From Portrait Mode Photo
will perform all steps necessary to produce a 3D image you can
preview and save into a file if you want to.
The Guides choice actually performs a number of manual staps as a
single routine:
•
•
•

Open the portrait photo using File > Open Image(s) > 3D.
This results in the picture at the left and its depth map at the
right.
From the “Depth” buttons use “Make 3D”

An online tutorial is found at
https://www.youtube.com/watch?v=MjqFpKpysDQ&t=1s.
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Image Editing
This Guide is meant for adjusting some of the aspects of an image
before processing it to a stereoscopic image. In part this is similar to
the manual process of an image.

Combine left and right
Given a left and right image, it is combined to a stereoscopic image.
Similar to the manual loading of both images (File > Open Image) and
subsequent combining to 3D applying the “Depth” Make 3D filter.

Repair anaglyphic
Similar to “Automatic” Repair Colour Anaglyphic filter. Converts the
anaglyphic stereoscopic images back to a full colour stereo image to be
output in the desired output format.

Align
Similar to “Automatic” Automatic Align filter. Corrects misalignment
and exposure of both images.
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Video
The guide options for creating a stereo movie are listed in the menu.

Whatever option you take, split your work in manageable parts to
reduce the risks.
It happens that for whatever reason, 3DCombine suddenly aborts. The resulting
file may be unusable. It is therefore advised to split up a movie in approx. 5 to
10 minutes segments and process these individually. Use a video editor to
recombine the produced 3D segments into a full movie. That avoids the
disappointment when a 30 minutes movie (taking about 4 hours to process)
crashes after 29 minutes runtime (over 3 hours processing) leaving you with
nothing.
On occasion it also helps to convert the movie into the same or a different
format and process that copy.

The source file must be suitable for its purpose. If a 3D tv set or
projector is targetted, ensure the input file has the high definition
aspect ratio of 16:9 – and preferably the exact pixel size of 1920 x 1080
pixels.
Online tutorials are found at
Introduction to 3DCombine 6 - YouTube (general introduction)
Convert a 2D movie to 3D in 3DCombine - YouTube (different Guides
modes for 3D movies)
2D to 3D video conversion with depth changes - YouTube (depth map
tracking)

Intelligent
The Intelligent option allows you select a 2D movie, then select the
desired output and let the application run to process the entire movie.
All intermediate steps are executed automatically and cleaned up
afterwards. No depth maps are ever seen.
When prompted, select the 2D movie (if needed, in 16:9 aspect ratio).

28
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Use the navigation window that opens to select the movie. Depending
on its size, it takes a few seconds to load it. When done, it is shown in
both preview windows (identical contents) and you’re asked to specify
the output format required.

The output format is one of the flavours mentioned earlier.
Once specified, click on “Save Video” button and specify the name of
the output.

The conversion process starts. Sit back and relax – this may take hours
to complete. About 4 to 8 times as long as the movie’s running time.
The user interface shows the left and right image of the stereo video in
the making.

Automatic Tracking
This is a variation of the “Intelligent” process. This method tries to
track motion between the frames. Where “intelligent” processes each
frame individually, Automatic Tracking uses information from earlier
frames to detect movement of the same object between frames.
Potentially this provides a better (evolving) depth map.
Once you specified the 2D movie to process, an additional popup
window appears in which you select the tracking method.
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Once the option is selected, you specify the output format and the
output file specification and proceed with the conversion.

Manual Steps (1 to 4)
The method with the most intervention possible, is the manual step
process. It is time consuming as it consists of three or four steps, each
taking their time to process. The entire process consists of four steps.
Each process can be restarted from the previous step.
In the first step key frames are generated. These are .bmp screenshots
of major changes in the movie image. Next, depth maps are generated
or manually provided for these images. The stereo process then uses
the images and maps to create the stereo movie. The better and the
more depth maps are generated, the better the final result.

Step 1 Generate Keyframes
Once the 2D movie file has been selected, a popup window asks to
generate depth maps for the keyframes. If you do not allow this, only
the key frames are generated.

Ideally each scene change should deliver a key frame image. Practise
shows a lot of images are skipped and you would need to manually
add a lot of keyframes after this step before proceeding to the next.
How to do this, is discussed further down this section.
Whether or not depth maps are generated, you need to use a parallel
output file. This is an intermediate step where all the original
information is kept and required. The output file is twice as wide as
the original source file (e.g. not 1920 but 3840 pixels wide).

30
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The final desired output is specified in the last step. Then the
information may be squeezed, coloured, interleaved and changed.

During the processing you see the movie as left image and the depth
map as right image.

When finished, this step produced a number of image screen grabs in
.bmp format.

They are all named “image_nnn.bmp” for screen frame grabs and
“depthmap_nnn.bmp” for the generated depth maps, where nnn is
the frame number.
The generated image and depth map files include names that are
appended with “b”. Those files are “backtrack” image files. For
example *_23.bmp and *_28b.bmp are two files covering the entire
scene between frame 23 and 28. Depth maps can be interpolated

3Dcombine - manual

31

between frames 23 and 28. From 29 onwards, the next scene starts,
potentially entirely different from the previous scene.
When you need more keyframes, add them manually. For this perform
the following steps:
•

load the movie again using File > Open Video > 2D left

•

Use the movie play buttons to move through the movie.
Either frame by frame (forward/back), play normally (play),
pause (unclick “play”). The “step left”/”step right” are not
useful here since both left/right images are identical.

•

For each key frame grab the image by pressing the “Save
Image” button. By default the image file is called
frame_nnn.jpg (or .bmp or other format – the type is
selectable). The “Skip” button allows you to go forward by a
number of frames (to be specified). The type of format is not
relevant: the image is used to create depth maps and is not
used later and can be discarded.

For optimum use of depth maps, you should consider a key frame at
the start and the end of a scene (the ones 3DCombine names “b”
frames). This way 3DCombine can use the depth maps of both key
frames to generate depth maps for all frames in between.

Step 2 Process Depth maps
A time consuming process is to provide depth maps for each of the key
frames generated. They can be generated for all keyframes created
automatically in step 1, but you may wish to redo all of them.
The way to create depth maps for key frames is no different from
creating depth maps for images. It is described in section “Creating a
depth map” on page 23.
When all depth maps have been created, they must be merged with
the original movie file used in step 1.
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The output file will be twice as wide as the original source file (e.g.
3840 pixels as opposed to the source file 1920 pixels). The left image
will be the original movie, the right image is the associated depth map.

Next, select the way the frames must be processed with the depth
maps.

Quick is the usual option. Higher Quality does a more thorough
processing of the depth map but for many purposes does not produce
a better stereo movie.
Next the question is popped to how depth must be created:
•
•

By applying the depthmap of the keyframe to all the
subsequent frames upto the next keyframe
Change the depthmap by interpolating between the depth
maps of the current and next keyframe. The latter only works
of course if the next keyframe is the last one of a scene (like
the ones 3DCombine names “b” files) .

The last option will give a better result. The best would be to create a
depth map for each movie frame but this requires a lot of time or
many assistants. The solution of using interpolation is illustrated in the
figure below.

3Dcombine - manual

33

Between the showing of a red rectangle and a green triangle, a blue
coloured circle approaches. It becomes bigger but also comes closer.
This means that its depth map representation also becomes larger and
less grey with each frame.
The keyframes are the first frame where the blue circle appears and
the last one. The total spans 8 frames. If we create depth maps for
each of the 8 frames, the depth maps would look like the series shown
in the middle film strip. If we decide to create a depth map for the key
frames, only 2 out of 8 frames have a depth map. The frames in
between slowly change from the first to the last. They can be
calculated as “something in between start and finish”.
Depending on the speed with which the blue circle moves, these
calculated depth maps may be accurate or not entirely fitting. But they
will be better than applying on the first depth map constantly or let
3DCombine make a guess on each frame.

If the next keyframe belongs to an entirely different scene it makes no
sense to use it to interpolate.

Finally, a new output file must be generated that combines depthmaps
with 2D movie. Each frame has its own hand made or generated depth
map.
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During processing you see the movie as left image and the depth map
as right image. This will become the output file contents.

Step 3 (optional) Post Process
The step can be skipped as it optimizes the depth maps in an
automated fashion and may bring little or no improvement on the end
result, yet takes an enormous amount of time.
This step processes the output file created in the previous step. At the
start this file is requested to be opened. It should open properly (in
parallel mode) but if not, a different format can be selected.

It will then match the depthmaps and ask for an output file
specification.
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The source file for this step must again be in parallel mode. The
processing starts when the “Start Video” button is pressed.
The interface shows the same type of information as in the previous
step: movie frame left and depth map right..

Step 4 Convert to stereo
The file created in step 2 (and optionally enhanced in step 3) is now
finally processed to a stereo movie. As input you need to specify the
file result from step 2 or 3.

This step 4 combines the flat frames with their depth maps to produce
the output file of choice (parallel, side by side, anaglyphic etc).
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Finally you indicate what the depth must be (disparity between left
and right eye image). The default 0.20 seems a reasonable setting.

A final optimalisation during processing can be specified or ignored:

Whether any of the optimzations will result in a better end result
depends on the state of the original movie. You may use them or
ignore them.
Then the processing can begin, showing the final movie format during
the processing. This will take some time again, so sit back and relax
again.
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Video editing

Combine left and right
There already are two movies – one for the left side and one for the
right side. You enter them both. 3DCombine then combines both to a
single stereoscopic movie in the desired output format.

Repair Anaglyph
Converts an anaglyphic 3D movie into a 2D full colour stereo movie the
the output format of choice (other than anaglyphic obviously)

Align
Corrects the video frame images on left and right for misalignment and
exposure.Similar to the “Automatic” Automatic align filter.

Vuze
Stitch a Vuze video into a panorama
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Part 3: Manual Conversion:
Open, Close and Save Projects
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Introduction
Rather than relying on the “Guides” wizards to create stereoscopic
images or movies, you may take things in your own hand. Most of the
processing works exactly the same way as when the “Guides” are
used, but you have a few more options available to select which files
to use.
The adjustments you can apply are specified in the next part, Part 4:
Creating Or Improving 3D Effects on page 47.
This part is mostly about opening and closing files as well as saving
filter settings as a project that can be reused later.
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The “File” menu
New
The “New” button closes whatever files are currently open to start
anew, as if you just started the 3DCombine application. You are
warned that any changes will not be saved. If you want that, first save
the current filter settings as a project (using File > Project).

Open Images
Using “Open Images” allows you to select what to do. You can open
one image pair or a collection. If you use one pair proceed as follows.
•
•
•

•

If you already have 3D images (parallel or otherwise) in a
single file, you can open that file and thereby opening both
left and right side image
You may select left and right images from separate files. Using
“2D Left” you select the left side first. Next you click on “1D
Right/Depthmap” to open the right side image.
If you have a left side image and a depth map to produce a
stereoscopic image, use the “2D Left” to open the 2D image.
Next click “2D Right/Depthmap” to load the depth map that
contains the depth information for the 2D image loaded as
left image. Ensure that the depth map uses the white colour
to indicate the shortest distance. Otherwise you first need to
invert this depth map using an image editor.
If you only have a single image, load it with “2D Left”. Using
other tools of 3DCombine you create the right side image.

If you want to process multiple images:
•
•

•

•
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Click “3D” and select multiple stereo pairs to import
Click “2D Left” and select all left side images. Next click “2D
Right/Depthmap” to load the corresponding right side images.
It helps to give left/right pairs similar names so they are loaded
in matching order
Click “2D Left” and select all flat 2D images. Next click “2D
Right / Depthmap” to select all depth map files for the
corresponding left side images. It helps to give left/right pairs
similar names so they are loaded in matching order
If you have number of 2D images, load them using “2D Left”
and use the 3DCombine tools to generate the right side
images.
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If you select multiple images you invoke 3DCombine’s batch mode.
This is shown by the appearance of two more buttons on the button
ribbon.

These “Back”/”Forward” buttons allow you to navigate through your
images and apply changes before you hit the “Save Image” button.

Open Video

Similar to opening images, if you use “Open Video” you can specify a
single movie:
•
•

•
•

If it is already stereoscopic, use the “3D” menu option and
specify in an additional question what sort of 3D movie it is
(parallel, anaglyphic etc) .
If it is 3D but as set of two 2D movies (left/right), you can open
the left hand side of the video clicking on “2D Left”. Next you
need to provide a right eye equivalent by clicking on “2D
Right”
If it is 2D, you can open it on its own using “2D Left” and use
other 3DCombine tools to generate the right side frames
Use “Dual” if you have a MVC stereo file or other video format
that embeds two video streams. It will then split both
components into their left and right frames. Note that “Side by
Side” stereo movies are not dual movies. They are essentially 2
dimensional with left/right frames side by side in the same
frame. Use the “3D” option for this.

This option is also used in the “Guides” between manual steps 1 and 2
when you want to make more keyframes and depth maps for these
frames.
Once the movie is successfully opened an additional set of buttons
appear that allow you to move through the movie.
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•
•
•
•
•

•
•

Rewind goes to the first frame of the movie
Back goes back 1 frame for both left/right movie
Forward goes forward 1 frame in both left/right movie
Skip goes forward a number of frames (you must specify this
number) for both left/right movie
Play simply plays the movie by moving forward through both
left/right movie
This button works as a toggle: when unclicked it pauses the
movie.
Step left – moves the left movie forward one frame. The right
movie does not change, If there is no left movie, nothing
happens.
Step right – move the right movie forward one frame. The left
movie does not change. If there is no right movie, nothing
happens.

Save 2D Images / Save 3D
After manipulation of an image, you may wish to store the result.

Use
•
•
•

“Left” if you only want to save the left side image
“Right” if you only want to save the right side image
Use “Save 3D” if you want to store the stereo image in a
format of choice (parallel, anaglyphic etc). You’re prompted
for both choice and file name.

Project
A project is a bit of a misnomer for most people as it does something
else than what you might think based on other application’s use of the
term “project”.
A 3DCombine project saves the list of operations (filters) performed on
an image or movie. All these steps (look at the “Filter” button to get a
list) can be saved as a “project”.
This way you can apply the same modifications to multiple images or
movies once these are imported into 3DCombine. Simply open the
project and all filters are executed on the open images or movies.
It is not a project in the sense of storing information about the movies
or images currently at hand and as a checkpoint of where you’ve come
to. It is not suitable to “save” the current state of affairs to continue at
a later time by reopening the project.
44
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With 3DCombine executing specific steps and output results into files,
there is less need for maintaining the traditional project information.
Input in 2D is always converted to 3D and output. The only
configurable information worth keeping in going from opening 2D file
to saving a 3D file are the application and settings of the filters.

Exit
Selecting this option stops the 3DCombine application.
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“Edit” menu
The Edit menu does not contain much useful options – if you expect
modifications on images of movie frames, you need to look at some of
the buttons and filters.

Details
The “Details” menu option gives information on the current image.

If you’re working on a movie, the movie details on frame rate, frame
size and audio type are given. This information may differ depending
on the type of movie you’re working on.

Undo
The Undo button undoes the last filter you applied. You can also use
the “Filter” button to list all filters applied and selectively remove
some or all.
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Part 4: Creating Or Improving 3D
Effects
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The 3DCombine interface
To perform certain steps in the process to create a sterwo image
yourself outside the “Guides” wizard, 3DCombine offers a number of
functions. The settings are applied to all stereoscopic images or all
frames of a movie.
If the size of the image has changed, its new size can be inspected
using the Edit > Details menu choice.
If you want to cancel a filter whole you’re working with it, simply
unclick on the button. You will then be asked if you want to save the
changes made using the filter or not.
To use these, you may first need to open a left image or movie using
the commands described in Part 3: Manual Conversion:
Open, Close and Save Projects.

The Button Ribbon
A few buttons on the ribbon will remain visible, others will be added
once an image or movie is opened.

Preview 3D
The “Preview 2D” button has been discussed in section Preview 3D
Button on page 18. It is used to see the result of the operations you
performed and allows you to store that result as a file on disc.

Redraw
Redraw refreshes the images in the left and right panels. This can be
useful if you've resized the window and want to resize the images
displayed to match.

Filters
The “Filters” button is a toggle switch. When clicked, it shows a list of
operations performed. Unclick it and the list disappears.
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Each of the filters listed can be selected and modified by clicking on
“Edit Selected”. This allows to change the Depth setting of 0.2 in the
“Make 3D” filter to another value. The change is executed on the
image in the 3DCombine interface.
In the same way you can undo any of the filters by selecting them and
click on “Remove Selected” or remove all filters by clicking on “Clear
All”. This way you revert to the initial display of the left image or
frame. This option comes in handy if you’ve performed operations you
rather undo to start again.

Navigation buttons
Once a batch of 2D images is loaded as left image the menu ribbon
with buttons is extended with navigation buttons to move to the next
image or back to an earlier image.

They are described in section Open Images on page 42
If a movie is added, there are more buttons, to allow for forward or
backward movement or skip a number of frames. And also to simply
play the movie.

These are described in section Open Video on page 43.
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To convert a 2D image or movie to 2D the “Depth” button will be the
most interesting one.

Simple Button
This button opens a menu with buttons that each can perform a
“simple” operation on an image or frame.

Most buttons will be self-explanatory. They work on both left/right
side images or frames.
Double vertically – Increases the vertical size of the images, stretching
all objects vertically. The effect looks similar to squeezing the image
horizontally by a factor of 2.
Halve vertically – Halves the vertical size of images. The effect looks
similar to horizontal stretching by a factor of 2.
Swap – swaps the left and right image or frame
Invert – inverts the colour of left and right image or frame. The result
looks like a colour or b/w negative
Get Saturation – shows left/right image or frame in a grey tone image
showing saturation of colour. White is high saturation, black a
minimum of saturation.
Flip – mirror the left, right or both images horizontally. The result is a
mirror image upside down. This is not a 180° rotation as all objects are
mirror-imaged. The vertical flip is called “Mirror”
Crop to Same Size – both left/right images are cropped to the
dimensions (in pixels) of the smallest. The larger image is cropped, not
reduced in size.
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Smooth – a (Gaussian) blur is applied to both frames. Repeated
smoothing makes the images more blurred
Mirror – In fact a “Flip” along vertical axis. Left and Right side of an
image are flipped. The operation can be performed on either left, right
or both images.
Convert to grey – colour images become grey tone images
Display Alpha - ?
Remove Alpha - ?
Add Alpha - ?
Get HLS - ? Stands for “hue, lightness, saturation. (Also known als HSL)
which are different variations to represent colour space such as RGB
(red, green,blue).

Tweak Button
This button opens a menu with buttons that each can perform a
“tweak” operation on an image or frame. Examples of the effects are
performed on identical pictures in left and right frame.
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Colour Filter – for each of the three colours red, blue and green as well
as for left and right image you can filter on colour. A value of 0 means
no filtering for that colour (colour remains). Values upto 255 mean
that colour is partly or entirely removed (255). So six questions are
asked before the tweak is performed.
Align Horizontally – One of the images is shifted horizontally by
number of pixels. Negative values mean shift to the left of the left
image. Positive values mean a shift to the left of the right image. The
example shows a shift of +200 pixels (width 1920 pixels)

Rotate Images – Left and right image can be rotated while the frame
border remains the same. Positive values mean rotating clockwise. The
example below shows 10 degrees of the left and 50 degrees for the
right image. Where unknown areas appear, the information is
“guessed”.
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Resize Images – both images are resized. You are asked whether this
has to be with maintaining aspect ratio or not.

In all cases width and height in pixels is asked for. With aspect ratio,
one of the settings is ignored to keep the ratio the same.
The “Grow” and “Shrink” seem to do the same if the same width and
height are specified.
Converge – The left and right images are moved closer (positive
values) or further (negative values) apart. At the same time the image
content is distorted. The example below uses a converge of 5.

Align Vertically – similar to Align Horizontally. Negative values shift the
left image, positive values the right image by the number of specified
pixels. You need to specify whether the new areas are filled or not.
The example shows an alignment of +200 pixels (with image 1080
pixels high).

Crop – after specifying where the left, right, top and bottom border
must be set, the image is cropped and resized to fill the width and
height of the original image. The example shows a crop of 100 pixels at
all sides.
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Pad – enlarging the image by specifying larger values than the current
pixel size results in padding. Smart Padding is a better option.
The example shows how a 1920x1080 image is padded to 2000x1200
by adding black around the frame.

When padded to a smaller size the entire image may become black.
Use the Smart Pad instead.
Smart Pad – similar to Pad but it will work with any given padding –
also when the image is reduced. It also keeps the entire picture and
uses whichever size can be filled completely when reduced in size. The
image below is padded to 1500x800 pixels. The pillar box sides have
become broader.

The image below is padded to 2500x1500 (effectively enlarged – the
image remains the same 1920x1080 but is padded with black)

Partly too large and too small (2500x900) compared to the 1920x1080
pixels frame size, results in the picture below where the 900 pixels
height fills the entire image, rescaled from 1080 pixels. The width is
padded to keep the image in proportion.
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Gamma – specify a different gamma value to make the image brighter
or darker.
Scale Image – the image is scaled in proportion by a percentage. The
new size can be seen in Edit > Details. In the interface the image
appears to remain unchanged since the interface scales it in the
opposite direction to show it. Edit > Details however shows the new
dimensions of the image.

Automatic Button
This button opens a menu with buttons that each can perform a
“automatic” operation on an image or frame. Automatic is just that:
you invoke a filter and it works to preset conditions, not requiring any
user settings. If you want to be involved, use the Simple or Tweak
filters.
The original left and right images are identical and shown below.
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Automatic Align – important for proper stereoscopic output is that
homological points are the the same height in both images (horizon at
the same height). This function repositions the two images to make
them align (by shifting them vertically).
Match – inspects both images and adjusts brightness and contrast so
both left and right look the same. This avoids strange stereoscopic
effects when the brain sees differently by each eye.
Auto scale – wrong name. It adjusts the brightness to maximize
contrast in both images.
Auto Converge – left and right image are moved closer together or
further apart (to do this manually, use the Tweak menu) for better
stereo effect. The number of pixels shifted is indicated.
Repair Colour Anaglyphs – adjust the red/cyan colours that separate
both images in a stereoscopic view in an attempt to produce it as good
a colour image as possible.
Crop Borders – remove black bars at top and bottom of the image.
Important if you want to vertically align the images without the bars
misfeeding information )using “Automatic Alignment”)
Automatic Rotate – rotate one or both images to reposition them to
be in alignment. Important if you want to use “Auto Converge”
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Find Edges – shows the edges round objects in the picture. Useful as a
temporary result to be previewed in 3D to perform alignments. Not
useful as permanent output (unless you feel very artistic).

Find Brightest – find the brightest pixels in left and right image and
copy them into the left image. This may cause a less sharp left image.
De-ghost – only relevant for imported interlaced or anaglyphic images
to remove ghost effects they may have.

Adjust
The buttons behind the Adjust button are meant to adjust the two
left/right images to give a better 3D effect. Some buttons also occur in
other button menus. Adjust is a manual operation and the user
decides on the setting values – unlike the “Automatic” filters.
In most options, one or two slider bars are shown below the left or
both images and you can shift these sliders rather than entering values
in a text box.

3Dcombine - manual

57

Adjust Alignment – allows to adjust the left image either horizontally
(left slider) or vertically (right slider). When the mouse hovers over one
of the sliders the help text underneath explains what shift applies.
The example below shows a horizontal shift over 294 pixels. See how
the right side image is padded with a black bar. (Shifting -294 pixels
shows the bar on the left image).

Rotate – rotate both images in opposite directions in values between 450 and +450 units (0 being upright).
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The example shows a rotation of 271.

Horizontal Crop – crop the left and/or right side of the image between
a value of 0 and 107. The example shows maximum crop on both sides.

Scale Right – modifies the right side frame by reducing or enlarging it
vertically or horizontally, causing a squeezed or stretched picture. The
left slider adjusts the horizontal scale, the right slider the vertical scale.
Note that although the interface tries to show the entire frame, the
unscaled side remains the same size.
The example shows a vertical scale of 997 and the resulting sizes of left
and right image (from Edit > Details). Initially both left and right had
values that only left has maintained.
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Non Linear – the entire frame contents remains, yet the middle part is
moved to in opposite directions inleft and right frame. The side
contents is squeezed or stretched.

Vertical Crop – similar to horizontal crop. Each slider crops either the
top *left slider) or bottom (right slider) of the frame.
The example shows a crop on top and bottom by 98.

60

3DCombine - manual

Brightness – adjust levels of darkness and brightness. The proper lit
picture has levels between 0 (black) and 255 (white). Reduce the
interval and several shades of grey become a single shade, causing the
overall picture to have fewer shades. In the extreme case where
darkness is moved from level 0 to 255, the entire frame becomes
black. In reverse, if the bright 255 is reduced to 0 the entire picture
becomes white.
The example shows the darker level 0 to become 115, leaving only
255-115=140 levels available to cover black to white rather than 255
levels.

Gamma (also in Tweak) – change the gamma level of the frame from 0
(dark) to 100 (bright).
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VR Button
This button opens a menu with buttons that each can perform a
operations on an image or frame for use in Virtual Reality glasses of
particular types.

Cardboard – Modify the stereoscopic image to fit a cardboard or
similar viewer. Used for view on mobile phones.
Fisheye – use 3D movies from fish-eye movie cameras (such as Lucid,
which is one of the output file options) to create a 3D panorama in any
format you want for use on a regular 3D tv or projector or anaglyphic
on a pc screen. An online tutorial is found at
https://www.youtube.com/watch?v=V1mwwp3fwfQ&t=158s
Vuze Stitch, Vuze Auto, Crop Vuze – Create panoramas for Vuze
camers. They are discussed in the same tutorial as the Fisheye.
Ocultus – Modify the stereoscopic image for use in Ocultus viewers.

Depth Button
When you click on the Depth button it opens a sliding window
revealing a number of buttons associated with depth in the image or
frame. It occupies two columns, but you can reduce it to a single
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column and expand it to two columns again by clicking on the chevron
button at the bottom.

Below the chevron an indication is given which frame of a movie is
currently shown or what image number.

Any result can be viewed by clicking the “Preview 3D” button and click
the “Save Image” or “Save Video” button after the desired type of
output has been selected (See section Preview 3D Button on page 18).
•

Create Depthmap creates a depth map of the current frame or
image. It needs to know which side to use for depthmap
creation or if a stereo movie or image is loaded how to create
it from the difference between both images.

In case of a 2D image or frame, the right image becomes the
depth map.
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•

Process Depthmap uses the depth map as right side image to
create a 3D frame. This processing can occur in various ways
and you must specify how you want it done.

•

Make 3D then uses the depth map as right side image or
frame to create a stereoscopic image or frame. You are asked
for the depth or disparity between left and right image. The
suggested 0.20 value normally suffices but you can
experiment.
You can use the “Preview 3D” button to display the result in
the way you want it (see Preview 3D Button on page 18).
Using the Edit > Undo reverts to the left side 2D image and
right side depth map. Create a new 3D image with a different
depth value if you wish.
Auto2D > 3D mimics the Guides “Intelligent” behaviour. When
you click this button, you’re asked whattype of 2D image is
available in the left frame.

•

•
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Next all steps of creating the depth map and creating the
stereoscopic image in Make 3D are performed in one sweep. If
the right image already contains a depth map, that one is
used.
Make Interlaced This creates 9 images of the left image. The
5th one is identical to the left image. The others are shifts to
left (1-4) and right (6-9) of the middle image. You can select
which right image gives the least distortion by filling in gaps of
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•
•
•

•
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background information to use as right image to create a 3D
pair.
Make 3D Tiled
Interlace
Rotate 3D image rotates the left image clockwise, generates
depth map and creates a right image (also rotated) The
generated right side looks bad as looking through a bathroom
window.
If you already generated a stereo pair, it is simply rotated
without distortion.

Invert inverts a depth map in the right image. White becomes
black and vice versa. This may be useful if the depthmap is
used in other applications that use black-to-white instead of
white-to-black depth maps.
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Part 5 Correcting depth maps
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Introduction
The depth perception in the end depends on how good the depth map
is that creates the right image from given depth information on objects
in the left image.
Using most of the “Guides” options, the depth maps remain invisible
to the user. But where you want to influence the results, you need to
manually change the depth maps. This must always be the case where
the automated procedures make the wrong guesses about the depth
of certain objects, causing some of the depth map limitations
discussed earlier in Depth map limitations on page 8.
In case of a movie conversion, you may use the “Guides” option for
performing the process in 4 steps. After the first step, you can enter as
many keyframes and associated depth maps as you wish before
proceeding with the second step where these maps are used to create
depth maps for each and every frame of the movie.
This part discusses how to create, modify and use the depth maps.
Much of it is already covered in section Creating a depth map on page
23.
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Create and save a depth map
Create depth map for image
You can create an entire depth map from scratch for an image using
the layer approach discussed in section Creating a depth map on page
23.

Use 3DCombine generated depth map
If you intend to improve on a depth map that 3DCombine created, you
need to output this depth map as a file and then modify its grey tone
contents to reflect proper distances. This can be done in any image
editor that supports layers as your changes can then be stored in
separate layers. Each of these layers can be adjusted without
disturbing any of the other layers. You may select a certain grey tone
using a wand tool and copy the selection as a new layer and adjust
that layer.
To create a depth map for an image perform the following steps:
•
•
•
•
•
•
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Load the image in the left frame
Click on the “Depth” button on the button ribbon
Click the “Create depth map” button on the menu that opens
Select the “Left Only” option as source for the depth map
The right frame now shows the generated depth map
Save the map using File > Save 2D Image(s) > Right
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Editing a depth map
The depth map is adjusted using any layer supporting image editor.
The final result must be stored in a flat file grey tone format such as
.jpg or .bmp.
Do save and keep the original editor file format that has all the layers
present. For Adobe Photoshop this is the .psd file.
This may come in useful if you need to make further adjustments if the
result shown in 3DCombine is not to your satisfaction.
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Recreating the stereoscopic effect
Recreating a stereo image
With the depth map created, it must be processed by 3DCombine into
a stereoscopic image.
Perform the following steps:
•
•
•
•
•
•
•
•

Import the flat image as left image using File > Open image(s) >
2D Left
Import the depth map as right image using File > Open
image(s) > 2D Right/Depth map
Allow processing the depth map by clicking on the Depth
button on the button ribbon of 3DCombine.
Process the depth map clicking on the “Process Depth map”
Create the stereoscopic image clicking on “Make 3D” button
Preview the result clicking on “Preview 3D” button on the
button ribbon in the format of choice such as parallel or
anaglyphic.
Repeat the steps above each time you revise the depth map
Save the final 3D image by clicking on “Preview 3D” button and
next on the “Save Image” button.

Recreating a stereo movie
Creating the stereo version of a flat movie is essentially identical to
creating a lot of stereo images that suggest movement.
Here most of the work is done using the “Guides” manual steps
described in section Manual Steps (1 to 4) on page 30.
In essence, you create key frame images for each first and last frame
of a scene and create depth maps for these. Either by creating them
from scratch using the key frame images or by using the generated
depth maps for these frames.
When a movie is imported, a number of play buttons appears on the
button ribbon. Navigate to the specific frames and handle them as you
would a single image.
The resulting depth maps must adhere to a standard naming, being
“depthmap_nnn.bmp” (other formats as .jpg are also allowed, but
.bmp are lossless and better for accurate depthmaps) for the scene
opening frame and “depthmap_nnnb.bmp” for the last frame of the
scene.
The postfix “b” indicates “backtrack” . You use this if in the production
of the 3D movie you want to use interpolation of the depth map
between first and last frame of the scene.
All depth map files must reside in the same folder as where the 2D flat
movie is stored for the “Guides” manual steps to work.
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Appendix A: Errors occurred: possible causes
3Dcombine sometimes doesn’t seem to do what you intended and
may give a clear reason or not. Some of these unclear reasons are
discussed here.
Unable to save file. As indicated by the message, this may be because
the output folder cannot be written to. Perhaps the folder is set readonly, perhaps you need administrative privilege to write to it. But the
same message also occurs when, during operation, the disc of the
output folder has become completely filled.
Sudden abort of application. This seems to happen during movie
conversion in any sort of “Guides” use. Reason unclear. Currently only
workaround is divide the movie in smaller parts and process them
individually, reducing the risk of losing work. Recombine parts using a
video editor. Because the output is SBS or anaglyphic most of the time,
any 2D video editor will work.
Output can not be opened in video editor. This may be due to the
output being produced with variable bitrate and the editor only
accepting fixed bitrates. Convert the output file to fixed bitrate using
any movie converter.
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Appendix B: External Tools
Searching for 3D tools on the internet quickly makes you realize a lot
of tools are not meant for stereo viewing but to assist in creating
objects to print in a 3D printer. A whole different ballgame therefore.
In this section a number of tools are mentioned, freeware as well as
commercial software, that may assist in your quest to produce stereo
images and movies from flat 2D files.
As with most freeware tools: be careful on what links you click as most
of their webpages are loaded with irrelevant adverts that try to
redirect you to other commercial tools. The installation files may also
lure you to “also install our recommendation” and before you know it
a lot of bloatware gets installed also.

Blu-ray and DVD ripping
•

•
•

AnyDVD HD (https://www.redfox.bz/en/anydvdhd.html)
continuation of the Slysoft AnyDVD software that removes
all encryption and allows a disc (DVD or blu-ray) to be played
regardless of region or encryption. And files can be copied
unencrypted.
DVDFab (http://www.dvdfab.cn/) software to rip DVDs and
blu-rays and shrink them to size if needed. Trialware.
MediaInfo (https://mediaarea.net/en/MediaInfo) – freeware
tool to inspect video files characteristics like are they
interlaced or progressive, what is their resolution, framerate
and other useful information. Integrated in Windows
Explorer. Use the “Tree View” for exhaustive information.

File joining/splitting
•

HJSplit (www.freebyte.com/hjsplit or
http://www.hjsplit.org/) – a program that either joins files
together (all with added filetype <name>.<type>.001 to 00n)
or splits one in a set of files of specified length (output
<filename>.<type>.001 to 00n).

•

Adobe PhotoShop (www.adobe.com) – expensive photo
editing program, currently only on “365” annual
subscription. Affordable version as “PhotoShop Elements”.
“Mother” of all image editors.
Corel – CorelDraw Graphics Suite (www.corel.com) – similar
to PhotoShop but far cheaper image editor, based on their
purchased “PaintShop pro” application. Comes in flavours
“Suite”, “Standard” and “Essential”. The latter two only on
Windows.
GIMP (http://www.gimp.org) – GNU freeware cross
platform image editor (amongst which are Windows and
Linux)

Photo editing

•

•
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3Dconverter DMAG1-9
(http://3dstereophoto.blogspot.com/p/software.html) – set
of macros that work with GIMP to create depth maps of
images. Created and maintained by Ugo Capeto. He
maintains a blog with lots of information on 3D creation on
http://3dstereophoto.blogspot.com/

Video editing and format converting
•

•

•

Adobe Premiere Pro and Elements (www.adobe.com and
https://www.adobe.com/products/premiere-elements.html
) – commercial movie editor. The “Elements” version is a
trimmed down (cheaper) version of the full-fledged Premiere
Pro.
Cyberlink Power Director
(https://www.cyberlink.com/index_en_US.html ) – a movie
editor (both picture and sound). If you intend to work on an
output file, do not chose its AVC/MPEG-TS output stream as
it has difficulties reading its own output in this format.
Wonderfox HD Video Converter Factory
(https://www.videoconverterfactory.com/dvd-videoconverter/) – free and paid versions of a HD video converter
from one format into many other formats. You may need to
disable the “hardware acceleration” if your video card
doesn’t work with this converter (producing 0 bytes sized
files).

Stereo Photo Editing
Stereo Photo Maker (SPM). http://stereo.jpn.org/eng/stphmkr/
Freeware program made in Japan. It has become the “de facto”
application to manipulate stereo images. You can create or add depth
maps, align images and a lot more. It is Windows based but can run on
Apple Mac and Powerpc’s if run in a Windows emulator. In part it
duplicates or complements 3DCombine’s features. It can make depth
maps only after downloading Google software.

Photo and Video players
There are lots of software video players on the market
VLC Media Player ( https://www.videolan.org/). Freeware movie
player by the Video Lan Community. Capable of playing most video
formats. It can play SBS movies (Tools > Effects and Filters > Video
filters > Advanced > Check “Anaglyphic”. The Side-by-side capability
started implementation but I don’t think it ever came to anything.
PowerDVD (https://www.cyberlink.com/products/powerdvdultra/features_en_EU.html) A commercial player that seems rather
strict in obeying BDA rules about preventing unintended types of use
like refusing to play bluray discs if your monitor is not digitally
connected (but uses VGA connections). Plays many movie and photo
formats and automatically switches to SBS if such a medium is inserted
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into its media library. Manually use Photo/Video > Change to 3D
Format > Side by Side
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3D
Above Below (Top Bottom), 8
Anaglyphic, 8
Create from Depth Map, 36
Cross Eyed stereo, 8
Parallel, 8, 13
Preview result, 18
Side by Side, 12
Side by Side (SBS), 8
3DCombine
Dockable Button Ribbon, 17
Installation, 11
modes of operation, 7
User's interface, 17
Above/Below stereo. See 3D
Adobe PhotoShop, 74
Adobe Premiere, 75
Anaglyphic stereo. See 3D
AnyDVD HD, 74
Aspect Ratio, 11
Button
Adjust, 57
Automatic, 55
Cancel, 19
Depth, 62
Filters, 48
Image batch navigation, 49
Movie Navigation, 49
Movie play/forward/back, 32
Navigation between images, 21
Preview 3D, 18
Project, 44
Redraw, 48
Simple, 50
Tweak, 51
VR (Virtual Reality), 62
Capeto, Ugo, 23
CorelDraw Graphics Suite, 74
Cross eyed stereo. See 3D
Depth Map, 7
Automatic creation, 25
Create, 23
Creating, 68
Editing, 69
Example, 23
for key frames in video, 30
For Keyframe, 31
Interpolating, 34
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limitations, 8
Processing, 32
Processing to 3D image, 70
Processing to 3D movie, 70
DMAG, 23, 75
DVDFab, 74
Errors and possible solutions, 73
External tools, 74
File Splitting. See HJSplit
GIMP, 23, 74
Guides, 20
Create 3D Images, 21
Create 3D Images - batch mode, 21
Create 3D Images - Intelligent, 21
Create 3D Images - Landscape, 22
Create 3D Images – Using Depth Maps, 22
Create 3D Video, 28
Create 3D Video – Automatic Tracking, 29
Create 3D Video - Intelligent, 28
Create 3D Video – Manual using Depth
Maps, 30
HD Video Converter Factory, 13, 75
HJSplit, 74
Key Frame, 30
MediaInfo, 13, 74
Menu Option
Details, 46
Edit, 46
New, 42
Open Image(s), 42
Open Video, 43
Save 2D Image(s), 44
Undo, 46
Output
Constant Bit Rate, 13
Variable Bit Rate, 13
Paralel stereo. See 3D
PowerDirector, 75
PowerDVD player, 75
Prompts
with Guides, 20
SBS. See 3D Side by Side
Sensio. See 3D Side by Side
Side by Side stereo. See 3D
Stereo Photo Maker (SPM), 75
Variable Bit Rate. See Output
VLC player, 75
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